Virtru for Google Vault unavailable
Incident Report for Virtru Platform
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 03, 2018 - 11:33 UTC
Identified
Virtru for Google Vault is not available for some users due to compatibility issues with the latest Google release. Virtru engineers are working to develop a solution. If you are unable to access Google Vault and need urgent assistance, please contact Virtru support.
Posted about 1 year ago. Jun 27, 2018 - 21:43 UTC
This incident affected: Administrative and Control Features (Vault).