Android Activation Unavailable via Google Sync
Incident Report for Virtru Platform
Resolved
Virtru released Android v. 2.3.5-p2 on February 5, 2018 to resolve this issue.
Posted over 1 year ago. Feb 22, 2018 - 14:09 UTC
Monitoring
Virtru has released a new version of the Android app (2.3.5-p2), which should be available for download from the Google Play store within the next hour. This new version addresses the current activation issue. However, please note that non-encrypted attachments and threading support will not be available with this version for GoogleSync accounts. We are continuing to work on the next version update that will fully resolve this issue.
Posted over 1 year ago. Feb 05, 2018 - 14:49 UTC
Update
Virtru engineers are continuing to work on this issue as a top priority. We are working closely with Google to make updates to our code to meet their new specifications. Our current expected timeline for resolution is on or around February 9. We will communicate additional updates and changes as available.
Posted over 1 year ago. Jan 31, 2018 - 22:39 UTC
Update
We have identified a specific data field that Virtru requests from the email server during the activation process ('BaseData') is no longer being returned for G Suite accounts due to a recent change made by Google. Requests to activate MS Exchange email accounts via the very same process do return the 'BaseData' field and activation completes successfully.

Virtru has a strategy in place to retrieve the requisite activation information via alternate means, which is actively in development. We are working to resolve the issue as quickly as possible. We will provide another update or resolution no later than close of business (ET) tomorrow, January 31.

Thank you for your patience.
Posted over 1 year ago. Jan 31, 2018 - 01:22 UTC
Identified
We have identified the underlying issue impacting mobile activation for G Suite accounts using the "Exchange ActiveSync" option. Our engineers are currently working on a fix. We will provide another update when this issue is resolved or by end of day (ET).
Posted over 1 year ago. Jan 30, 2018 - 18:19 UTC
Investigating
The Virtru Android app cannot currently be activated for G Suite accounts using the “Exchange ActiveSync” option. An update to the Google Sync protocol is preventing the app from fetching the required information from the server, resulting in activation failure. We are investigating alternative ways to obtain the same information from the server and will update the app when a solution is found. In the meantime, the app can still be activated via IMAP using the “Gmail / Google Apps” option.
Posted over 1 year ago. Jan 29, 2018 - 17:21 UTC