Reports of Virtru not working on Comcast Business Internet
Incident Report for Virtru Platform
Resolved
We have been able to confirm that disabling SecurityEdge OR adding Virtru endpoints to the Allow List will fix the issue. A list of Virtru endpoints can be found here: https://support.virtru.com/hc/en-us/articles/115004987954

At this point, we are marking the issue as resolved as there is no additional action Virtru can take. We continue to push Comcast to resolve this on their side, but in the meantime, the steps above should resolve the issue for any impacted customers.

We still recommend Comcast Business customers escalate this to their Comcast Representative.

If you have questions, don't hesitate to contact us at support.virtru.com
Posted Sep 23, 2021 - 14:10 UTC
Identified
We have confirmed that Comcast Security Edge is blocking Virtru. If you are a Comcast Business user, we recommend taking the following action:

1. Add all Virtru required endpoints to the Allow List in your Comcast Business and/or SecurityEdge account. If that doesn't work, we recommend disabling Security Edge. A list of Virtru endpoints can be found here: https://support.virtru.com/hc/en-us/articles/115004987954

2. Contact your Comcast Business Representative and let them know this is an urgent issue blocking your ability to conduct daily business. If your Comcast Representative needs more details about Virtru or the issue, you can contact our support team at support.virtru.com and we are happy to assist.
Posted Sep 21, 2021 - 14:05 UTC
Investigating
We have been made aware of errors and issues with Virtru when used on Comcast Business Internet. The issue appears to be on the Comcast side and we are attempting to get clarity from them on why this is occurring and what we can do to prevent it.

We recommend impacted accounts take the following action:
Add all Virtru required endpoints to the Allow List in your Comcast Business and/or SecurityEdge account. A list of Virtru endpoints can be found here: https://support.virtru.com/hc/en-us/articles/115004987954

While this is not an issue with the Virtru platform, we will continue to provide updates here and assist all impacted customers as best we can. We also recommend all impacted users notify Comcast so they can prioritize this issue accordingly on their side.
Posted Sep 20, 2021 - 20:02 UTC
This incident affected: Virtru Corporate Website and Virtru Secure Email Clients.