Virtru Backend Service Outage
Incident Report for Virtru Platform
Resolved
The incident is resolved, and all Virtru systems are operational. Please let us know if you experience anything unexpected.
Posted May 30, 2020 - 19:29 UTC
Monitoring
A fix has been implemented and we are Monitoring our fixes. There may be some instances where performance is degraded, we will be working on this until the issues is marked resolved.
Posted May 30, 2020 - 17:31 UTC
Identified
We have identified the issue, and are working on a fix. At this time Encrypt and Decrypt are working, but inconsistently. More updates to come.
Posted May 30, 2020 - 17:09 UTC
Investigating
We are back to investigating again, our service was back up recently, but is back down again. We are back to investigating, and will be updating this status page throughout the incident. Encryption and Decryption are currently both down, this includes all of our clients, including Gateway.

Gateway messages that should encrypt, will queue up for a period of time, then bounce until we resolve the ongoing issue.
Posted May 30, 2020 - 16:56 UTC
Monitoring
We have identified the issue and put in a fix, we will continue to monitor for additional degraded service before resolving the issue. If you have experience any issues feel free to reach out to our support, at support@virtru.com.
Posted May 30, 2020 - 15:35 UTC
Update
We are continuing to investigate the issue, and will keep this page up to date. We hope to have this resolved as soon as possible. Encryption and Decryption are currently both down, this includes all of our clients, including Gateway.

Gateway messages that should encrypt, will queue up for a period of time, then bounce until we resolve the ongoing issue.
Posted May 30, 2020 - 14:22 UTC
Investigating
Virtru is currently investigating a backend service outage, further details to follow.
Posted May 30, 2020 - 11:38 UTC
This incident affected: Virtru Secure Platform Clients and Virtru Secure Reader.