Secure Reader degraded
Incident Report for Virtru Platform
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 00:09 UTC
Monitoring
Virtru has implemented a fix for the 404 Not Found errors and we're monitoring results.
Posted Dec 14, 2023 - 20:57 UTC
Investigating
Secure Reader is continuing to return intermittent 404 Not Found. We are investigating.
Posted Dec 14, 2023 - 20:26 UTC
This incident affected: Virtru Secure Reader.