Virtru for Drive: file sharing not working
Incident Report for Virtru Platform
Resolved
This incident has been resolved and a fix has been released. If you are still experiencing issues, please try refreshing your page. If the issue persists contact Virtru Customer Support.

Thanks for your patience and understanding while we worked to get this resolved.
Posted Sep 27, 2023 - 13:28 UTC
Update
A new release with the fix has been submitted to the Chrome Store for review. Once it is approved, we will push the release live and provide another update here.
Posted Sep 26, 2023 - 21:38 UTC
Update
We are continuing to work on a fix for the issue.
Posted Sep 26, 2023 - 21:12 UTC
Update
We are working through an issue uncovered in testing. We hope to have this resolved and release the patch as soon as possible.

We will provide another update as soon as we have one.
Posted Sep 26, 2023 - 13:53 UTC
Update
We are testing a potential fix for the issue. We will release the fix as soon as it passes internal testing. We will provide another update at that time.
Posted Sep 25, 2023 - 22:20 UTC
Identified
Today, we started noticing failures in our internal testing around sharing files with Virtru for Drive. From our investigation, recent Google changes to the Share function disrupted our extension’s ability to jump into the sharing process.

This is a top priority for our team and we are working to release a patch as soon as possible. We will provide another update as soon as we have one.

Only Virtru's Google Drive product is impacted by this issue.
Posted Sep 25, 2023 - 19:43 UTC
This incident affected: Virtru Secure Email Clients.