We continue to monitor the situation to ensure the issue is fully resolved.
Posted Nov 20, 2025 - 18:33 UTC
Identified
We've received reports of Secure Replies sent by the O365 add-in not displaying fully. Our team has identified the issue and is actively working to patch it.
No other Virtru products are impacted. We will provide another update as soon as we have one.
Posted Nov 20, 2025 - 18:01 UTC
This incident affected: Virtru Secure Email Clients.