ACM increased error rate
Incident Report for Virtru Platform
Resolved
A backend database experienced brief connectivity issues which resulted in health checks marking our ACM service as unhealthy, preventing requests reaching the service. No data loss has been observed, but customer encrypt/decrypt operations would have failed during the outage period (~10 minutes). Virtru will be conducting an RCA to determine further reliability improvements to implement.
Posted Oct 06, 2023 - 20:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 06, 2023 - 20:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2023 - 20:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 06, 2023 - 20:22 UTC
Investigating
We are currently investigating increased error rates on our ACM service which handles encrypt/decrypt key management operations.
Posted Oct 06, 2023 - 20:17 UTC
This incident affected: Virtru Secure Email Clients, Virtru Secure Reader, Virtru Secure Share, and Hosted Gateway.