AWS Lambda Incident
Incident Report for Virtru Platform
Resolved
All services appear functional, Virtru will conduct additional analysis next week to confirm no residual issues with any product or feature.
Posted Nov 24, 2021 - 21:10 UTC
Monitoring
AWS has provided the following update: "We have identified the root cause within Lambda that is causing the increased error rates for function invocations within the US-EAST-2 Region. The subsystem responsible for executing functions is currently impaired and we are working to resolve it. We have seen some improvement in Lambda function invocation error rates and believe that this will continue as we take steps to resolve the issue. Other AWS services, including AWS Management Console, API Gateway, and Batch, are experiencing elevated error rates as a result of this issue."
Posted Nov 24, 2021 - 20:12 UTC
Identified
Error rates have increased again, we continue to monitor
Posted Nov 24, 2021 - 19:37 UTC
Monitoring
Error rates have decreased and all services appear to be operating normally.
Posted Nov 24, 2021 - 19:13 UTC
Update
Certain domain sync events and CKS key rotation functionality may also be impacted during this outage.
Posted Nov 24, 2021 - 18:53 UTC
Investigating
Virtru is monitoring an issue with the AWS Lambda service which provides functionality to certain Virtru features. The Virtru Dashboard and Audit products may not show the most recent data during this outage. Encrypt/decrypt functionality not impacted, and no data is lost.
Posted Nov 24, 2021 - 18:52 UTC
This incident affected: Administrative and Control Features (Virtru Control Center, Audit).