Everything is operational, but we are continuing to monitor the situation.
Posted Apr 23, 2025 - 22:43 UTC
Monitoring
Mail sending is improving. We are closely monitoring the situation and working to ensure all systems return to normal.
Posted Apr 23, 2025 - 22:10 UTC
Identified
We have received reports of system generated emails not delivering. This issue impacts most system generated emails (sent from virtru.com), including: - Verification emails - Activation Emails - Secure Share Emails
The issue does NOT impact delivery of emails sent by Virtru customers via the Gmail Chrome Extension, Outlook Extension and Add-in, or Virtru Gateways.
The issue is tied to an outage at SendGrid (https://status.sendgrid.com/). We are monitoring the situation closely and actively investigating alternatives.
We'll provide another update as soon as we have one.
Posted Apr 23, 2025 - 21:56 UTC
This incident affected: Administrative and Control Features (Virtru Control Center) and Virtru Secure Email Clients, Virtru Secure Reader, Virtru Secure Share.