Secure Reader down
Incident Report for Virtru Platform
Resolved
Secure Reader is now functional. Virtru is investigating root cause. There was no impact to other services or data.
Posted Dec 14, 2023 - 17:46 UTC
Investigating
Virtru is investigating an issue with Secure Reader. It is currently returning 404 Not Found.
Posted Dec 14, 2023 - 17:32 UTC
This incident affected: Virtru Secure Reader.