DNS Issues
Incident Report for Virtru Platform
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 02:44 UTC
Monitoring
We have implemented a fix and are monitoring results.
Posted Nov 16, 2023 - 00:01 UTC
Identified
We are implementing a fix now
Posted Nov 15, 2023 - 23:53 UTC
Investigating
Virtru endpoints are currently down due to DNS resolution issues. We are investigating.
Posted Nov 15, 2023 - 23:33 UTC
This incident affected: Virtru Secure Email Clients, Virtru Secure Reader, and Virtru Secure Share.