A fix has been implemented. We are continuing to monitor our systems to ensure all performance returns to normal.
Posted May 28, 2025 - 19:41 UTC
Identified
We're also seeing sporadic errors when decrypting Secure Share files.
We are actively working to resolve the issue
Posted May 28, 2025 - 19:15 UTC
Investigating
We've observed an uptick in errors when uploading files in Secure Share. The issue does not appear to be impacting all users and files, but we are actively investigating.
No other products or services are impacted. We'll provide another update as soon as we have one.